Follow

Error Connecting to Navision Native Databases on 64-bit Windows

Symptoms

  1. You are unable to configure a DSN.
  2. You are unable to see a previously created DSN in the ODBC Administrator.
  3. You are unable to see a previously created DSN in TX.

Cause

On a 64 bit version of Windows, ODBC connections are separated in bit specific lists. 32 bit applications can only see a DSN created on the 32 bit side of Windows. And likewise 64 bit applications can only see a DSN created on the 64 bit side.

When you access the ODBC Administrator which is by default located in Administrative Tools -> Data Sources (ODBC) you are using the 64 bit version (file located in %SystemRoot%\system32\odbcad32.exe)

Resolution

  1. Install a 32 bit version of TX. The bit-version of TX can be identified in the last part of the full version number, as i.e. 14.0.3.32 or 14.0.3.64 for 32- and 64-bit versions respectively.
  2. Configure the system DSN(s) using the 32 bit ODBC Administrator from Microsoft, located in the following path: C:\ %SystemRoot%\SysWOW64\odbcad32.exe
Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.