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Error: "Timeout expired"

Symptoms

You receive an error like the following:

Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.
Error during Data Processing for Table: <TABLENAME>
Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.
Stored Procedure: [dbo].[usp_XXXXXX_Clean]
Parameters:
@Debug = 0
@Version = 182
@LoadDate = 09-01-2012 16:59:06

Cause

If you do not change the default timeout settings, any query on the staging as well as the DW database will timeout after 100 seconds.

Resolution

To change the timeout setting and solve the described timeout problem do the following on the database in question (stage or DW):

  1. Right click on the staging/dw database in TX and select Edit.
  2. At the bottom of the window change the Command Timeout to a higher value, e.g. 3600 for a one hour timeout)

This article applies to: timeXtender 4.5, tX2012, TX2014.

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3 Comments

  • 0
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    Thomas Lørup Duun

    Hi Ian,

    If you set it to 0 (Zero), then it is open ended.

     

  • 0
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    Ian Cockcroft

    What is the maximum this can be set to?

    is it possible to set it to open ended?

    I get this error on one particular table after 8 minutes.

    this source is a view. the source has a cte and pivot and running it in SQL takes 30 minutes.

    (I am looking at ways to make the view faster.)

  • 0
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    Hansen, Mikkel Hecht DK - NOH

    Hi.

     

    Do you need to deploy for the change to have effect?

     

    Or save as deployed version?

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