Follow

Which bit version of TX DWA should I download?

TX DWA software comes in two bit versions: 32-bit and 64-bit.  In most cases, you will want to use the 64-bit version, but there are some exceptions to this rule.  This article will briefly cover the factors you should take into consideration when making this choice.

What is a bit version?

A bit version refers to how your computer processes information.  64-bit computers are able to handle some tasks faster than their 32-bit counterparts.  Most new computers use 64-bit architecture as a result.

Why is this important? 

TimeXtender can only work with programs and plugins of the same bit version.  This is usually only a concern if you have older IT infrastructure, or need to include legacy data sources. 

Potential bit version conflicts

By far the most common bit version conflict is with legacy Excel data sources.  The reason for this is that the old .xls spreadsheet driver only supports 32-bit computing.  This is such a common problem that we've created a guide for it, which you can find here

Another potential source of bit version conflict is with legacy database types.  Older versions of Oracle, DB2, or Navision Native may require adapters that are only available in 32-bit versions. 

If you have a 32-bit operating system, you won't be able to even get the 64-bit version of TX DWA to start.  This is quite rare in BI environments, but would require you to only use the 32-bit TX DWA software.

I have 32-bit data sources.  What should I do?

There are three things you can try:

  • Update or alter your data sources to allow the use of 64-bit adapters.
  • Use both 32-bit and 64-bit TX DWA versions, as shown here.
  • Use only 32-bit TX DWA.

Help!  I installed the wrong bit version and want to switch!  What do I do?

Switching bit versions of the TX DWA software is very easy.  To do this, make a note of your license activation code, uninstall TX DWA 64-bit version, and then install the 32-bit version.  Simply activate the 32-bit software and you're good to go.

Note that if you are using an older version of the TX DWA software, this you may need to upgrade to the newest version of TX DWA or request an older version of the software from TimeXtender Support.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.