Follow

The User Interface

The User Interface

The Discovery Hub user interface is a standard Windows application with a menu bar, a toolbar and a number of tabs that contain the different objects you will be working with. This section provides an overview of the interface.

The Menus

The commands, settings and tools available in Discovery Hub are split between two menu locations. The general commands, such as new, open, find, refresh, options, help, can be found in the menu bar. Commands related to a specific object can be found in the shortcut menu that appears when you right click the object.

For easy access to the most used commands in the menu bar, a subset of the commands can also be found in the toolbar just under the menu bar.

A lot of the most used commands have keyboard shortcuts. On all menus, you will notice that the keyboard shortcut to a command is displayed to the right of the command in the menu.

The View menu

This menu contains all the commands related to how the project is displayed.

Almost any object in Discovery Hub can be opened in a new window by right-clicking it and clicking Open in New Window. On the View menu, the open windows are listed under Open Windows to give you an easy overview if you find yourself with a lot of open windows.

On the View menu you can also customize the user interface by toggling the display of different elements:

  • Data types: When checked, the data type of fields is postfixed to their name.
  • Deprecated features: When checked, deprecated features are shown in the user interface. We recommend that you to keep this disabled for a cleaner interface.
  • Highlight descriptions: When checked, objects that have a description are displayed with bold text in the tree. Descriptions are added from the shortcut menu on an object.

The Reports Menu

In the Reports menu, you can find items related to previous and future executions:

  • Validation errors and warnings, i.e. rows of data that have violated a validation rule on a field or table.
  • Execution queue log
  • ODX execution and service log
  • ODX task schedule

The Solution Explorer and tabs

In the Solution Explorer, all the top-level objects in your solution are listed, such as data warehouses, semantic models and OLAP servers. Double-click an object, or click Open in the shortcut menu, to open the object in a new tab in a new tab group.

You can have as many tabs and tab groups as you like - or rather, as many as you can fit on your screen! When you save and close a project, the tabs you have open in are saved as a user setting. The next time you open the project, the same tabs will be available.

For rearranging tabs, you can use drag and drop or shortcut menu on tab header. You can move tabs between tab groups, and reorder tabs within tab groups. Tab groups can be moved from the shortcut menu on the tabs in the group.

You can drag and drop tables and fields between tabs in different tab groups, e.g. from a data warehouse to a semantic model.

Go to Source Table/Field

To ease navigation between tabs, a "shortcut" is available. The Go to Sourcecommand selects and displays the source table/field to make it easy to track where a specific table/field comes from.

Go to Source is available on the following objects:

  • Tables on semantic models, data exports and Qlik models
  • Mappings under tables on data warehouses
  • 'Copy' mappings under fields on data warehouses

If the source table/field exists in an open tab in another tab group, the source table/field will be selected there. If not, a new tab in a new tab group will open to show the source table/field.

To go to a source table/field

  • Right click the table, field or table mapping and click Go to Source Table/Field.

Note: Since tables on the ODX data storage are not listed in the UI, Go to Source is not available if the source is a table/field on the ODX data storage.

Color Theme

If you would like to easily tell different installations of Discovery Hub apart, or if you are simply tired of the default colors, you can choose another color theme for the application. The color theme is saved in the user settings for the specific version of Discovery Hub.

A color theme in Discovery Hub consists of a theme - light or dark - in conjunction with an accent color. There are five predefined accent colors available in Discovery Hub, giving you a total of ten color themes.

To change the color theme

  • On the Tools menu, click Options and then click your preferred theme in the Theme list and your preferred accent color in the Accent Color list.

If you use multiple environments, you can select a color theme for each environment to make them easier to tell apart. The color themes available for environments are different from the regular color themes to make sure they stand out when you apply them.

The Status Bar

The status bar in the bottom of the window contains information about the application and the currently open project, if any, and serves as a useful shortcut to some settings. The status bar can contain the following items, depending on configuration:

  • The name of the currently open project with the version number in parenthesis. In front of the project name, an icon shows you if all changes have been saved (green) or there are changes waiting to be saved (red). Click this to open the Open Project window.
  • The name of the repository server and database. Click this to open the Options window on the Project repository tab.
  • The name of the current environment if any. Click this to open the Environment properties window.
  • The license type and what company it is registered to. Click this to open the License information window.
Was this article helpful?
0 out of 0 found this helpful

0 Comments

Please sign in to leave a comment.