Follow

Missing CData providers after Upgrade

This article applies to 20.5.x and later versions of TimeXtender.

Symptoms:

After upgrade to version 20.5.x of TimeXtender, your existing project is unable to use previously installed CData providers.

Cause:

Due to the product name change, new folder paths are created after upgrade.  As a result, existing CData providers are not detected from previous install on the same machine.

Old Path:         C:\ProgramData\Discovery Hub\Discovery Hub\CData Components

New Path:       C:\ProgramData\TimeXtender\TimeXtender\CData Components

Workaround:

  • Manually copy (or move) the folder content from Old Path to New Path (as shown above).

OR,

  • Download the missing components again. 

            Go to Tools -> Manage CData Providers -> Add to re-download the drivers.

Note:

The providers installed from Tools -> Manage CData providers are installed in the folder below.  Those are used in a Business Unit data source.

C:\ProgramData\TimeXtender\TimeXtender\CData Components\ 

The providers installed from ODX Data Sources -> Manage Data Source providers include both CData and TimeXtender providers.  Those are installed in the folder below, and are used in an ODX data source.

C:\ProgramData\TimeXtender\ODX\Components\CData\
Was this article helpful?
0 out of 0 found this helpful

0 Comments

Please sign in to leave a comment.