Skip to main content
Question

ODX loads failing on BC schema changes - sync every run instead?

  • September 21, 2026
  • 1 reply
  • 14 views

darrirafn
Starter
Forum|alt.badge.img

Hi all,

We have regular ODX loads that periodically fail because of schema changes in Business Central (e.g. a new column added). The fix is straightforward: sync the metadata and rerun.

I'm considering just adding the metadata sync step before every ODX load to avoid these failures altogether. Is there any downside to syncing every time? Could it cause unexpected behavior, longer run times (probably only a few minutes?), or anything else worth watching for?

My instinct is that it's still better than having a load fail over a single new column, but wanted to check if this should be standard practice or if there's a reason this isn't already standard practice.

Interested to hear your thoughts.

1 reply

rory.smith
TimeXtender Xpert
Forum|alt.badge.img+8
  • TimeXtender Xpert
  • September 21, 2026

The effects of automated synchronisation differ a bit per source type: if you have a CSV source where someone clears out the directory (accidentally, or part of the truncate+reload process for source data) and you synchronise against an empty folder, you could lose the metadata.

In your case it is interesting that adding fields in the source would result in an error, I would expect that on an incompatible type change but not on adding a field. Note that even if the automated synch does not result in errors, you may still get them on moving the data in to a DWH / Prepare as there is also a synchronisation between the ODX Server and DWH it is mapping into or between the Ingest and Prepare(s) it maps into. You cannot schedule or automate this synch as far as I am aware.

You should be able to know when your BC instance will be updated by Microsoft and be able to schedule a maintenance moment around that to capture any metadata changes.