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Symptoms

When trying to synchronize or execute a Dynamics 365 Business Central data source, the following error is thrown.

AADSTS50078: Presented multi-factor authentication has expired due to policies configured by your administrator, you must refresh your multi-factor authentication to access '<GUID>'. 

Cause

The “Authorize OAuth” that creates an OAuthSettings.txt file may have expired.

Resolution

Clicking the “Authorize OAuth” button may not resolve this error. In those instances, you will need to browse to the folder that contains the OAuthSettings.txt file and remove this file. Afterwards, click the “Authorize OAuth” button again, and this time you may be presented with a dialog to choose the email address or account that will be used in the OAuth request.

To see where the OAuthSettings.txt is located, review the settings for the data source.

For a TimeXtender Ingest Instance data source, this will be in the TimeXtender Portal and displayed under the data source as the “OAuth settings path.”

After removing the file, you right-click on the Ingest Service data source in the TimeXtender Data Integration application and select “Authorize OAuth” to initialize the OAuth request.

 

For a TimeXtender Classic Business Unit, you need to right-click on the Business Unit data source and select the “Edit BC 365 Provider” option to open the dialog that shows the path to the “OAuth settings file.”

After removing the OAuthSettings.txt file, click the “Authorize OAuth” button in the dialog above to initialize the OAuth request.

 

 

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