SYMPTOMS
A data source that is using the TimeXtender REST API Data Provider fails with the following error message.
System Exception: Failed to execute request for endpoint ‘<Endpoint Name>’
One or more errors occurred.
A task was cancelled.
System.AggregateException: One of more errors occurred → System.Threading.Tasks.TaskCancelledException: A task was cancelled.
Additionally, a review of the log files may indicate that pagination is working and that a number of pages are successfully loaded for the endpoint that is referenced in the error, but eventually the loading operation gets stuck on a particular page and after retrying the load for that page three times the “A task is cancelled” exception is thrown.
Cause
A likely cause of this error is that the timeout period for loading the data has been exceeded. There may be other edge cases, but this is the most likely cause.
Resolution
There are two ways to help mitigate the problem of exceeding the timeout period.
- Reducing the page size
- Increasing the timeout period
Reducing the page size will depend on how the endpoint has configured the page size, as there are different ways of doing this.
Increasing the Timeout Period can be done in the TimeXtender Portal using the following Misc setting.

Reference Ticket
37252