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User interface elements blurry, very small or missing


Thomas Lind
Community Manager
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Symptoms

The user interface looks blurry, items are very small or items are missing from the user interface. This may only happen when logged into a remote desktop session.

Error Message

None

Cause

Issues with display scaling.

The application is displayed in another display scaling factor than it was initially opened in

TimeXtender is DPI-aware, which means that it should display properly in the scaling factor of the primary monitor. However, if you move the window to a monitor with a different display scaling factor, Windows will scale the application. Since this basically resizes the application like you would enlarge a picture in a photo editor, this will make the application look slightly blurry. Even when text and UI elements look crisp, bitmap elements in the user interface, such as icons, might look blurry since they are not rendered for all scaling factors.

The application is displayed in a custom scaling factor

While there should not be issues with incorrect item size and missing items in standard scaling factors such as 125%, 150% or 200%, custom scaling sizes are not guaranteed to work.

Resolution

Ensure that your computer's display scaling factor is not custom and the same on all monitors. 

  1. On the Start Menu, click the settings (gear) icon
  2. In Windows Settings, click System
  3. Ensure that the value in Change the size of text, apps, and other items list is the same for all monitors.

     

If you are having this issue on a remote desktop connection, this resolution will not work unless you follow these steps carefully:

  1. Sign out from your remote desktop connection. Simply "disconnecting" will not work. You must find the Sign out option under the start menu or power options and choose that exact option.  This is because the connection must be completely reset for the fix to work properly. 
  2. Adjust the scaling on your local machine.
  3. Alternatively delete the hidden Default remote desktop file. You may need to turn on hidden fields to see it before being able to delete it.
  4. Reconnect to the remote desktop. The change should take effect. 

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