Ask questions and find answers about TimeXtender Data Integration and TimeXtender Classic desktop applications
Recently active
Hi,I’m trying to load an Excel file from a OneLake. As OneLake is a rebranded version of Data Lake Gen2, my assumption is that it should be possible to use existing CData features to load data.I have a working setup where we use CData’s Excel provider (version 23.0.8585.0) to load an Excel sheet from a Data Lake Gen2 I explicitly configured the connection type as ADLS Gen2. Actually I was hoping that this configuration would work after changing the [Azure Storage Account] and [URI] to the OneLake parameters, but unfortunately that doesn’t work Error message: Looking into the logs, I see that CData tries to connect to *.dfs.core.windows.net. However, the uri of OneLake is *.onelake.dfs.fabric.microsoft.com. Manually entering the abfss:// uri did not work here Is it correct that CData is not yet compatible with OneLake, even though techniques under the hood are similar? Documentation on https://cdn.cdata.com/help/RXJ/ado/default.htm does not mention it (yet).Did anyone manage to load da
We have observed an inconsistency in the field order when adding a new table from the ODX to the DSA. Depending on whether we use the "Add New Table" or the "Add New Table with Field Selection" option, the fields are either randomly arranged or aligned with the source database.When we use “Add New Table” we notice that all fields are somewhat randomly arranged. When we use “Add New Table with Field Selection” and then check all the boxes the order is exactly as in the source database (as expected). How come that there is a difference? Is this on purpose? Thanks (TimeXtender 6346.1)
I Have Invoice date column in my table, i want to export data of last 10 weeks, what are ways to do it in timextender
Hello,We’re getting the following error when executing a table in DSA.ODX object synchronization detects no changes, and our ODX source is synched as well.I’m guessing the ORDER is an order by… Any idea what causes it? Thanks
Dear sir,In TX version 20 you can easily go back in time to an earlier version of your TX project.I am looking for going back in time to an earlier version of the MDW/SSL layer in TX version 21.I am running version TimeXtender 6143.1.Is this possible in the latest 6143.1 TX version ?Regards,Arthur
Hi, Please can you suggest on the following : Export to Data Lake is depreciated by Microsoft in Oct 2024 this year. So, what is the best alternate solution to extract the data from ERP FO solution for reporting? How to extract data from Field Service & CE ERP solution? OData connector is not good option as it is very slow & I cannot build incremental load on this.
Below is error message when trying to create custom view, how can i sove it@Christian Hauggaard
Hi, I created a field StorageReportIndicator in a table to rank the records in the table. This rank is a SQL window function RANK which combines table fields initially loaded from the data source (StorageUnit and ReferenceDateTime below) and lookup fields via table joins (DSA.Datum table, fields WeekKey and DayOfWeek). Goal is to have a rank to determine the first record of each week for each storageUnit. The outcome afer execution is that all records have rank 1 which is incorrect. I verified this with the same SQL statement in Management Studio.Could it be that this window function does not have the right result since the lookup is done after the rank is calculated? Note, the table is not historical and incremental. Anyone with experience with this case and is there a proper solution?
As shown in Figure Syncronize Task is sucessfully completed, but Transfer Task gets an below error “System.Data.SqlTypes.SqlTypeException: SqlDateTime overflow. Must be between 1/1/1753 12:00:00 AM and 12/31/9999 11:59:59 ”PM even though my date range starts from 2002 and ends at 2023.Even though after suggestion by @Christian Hauggaard i have made changes in setting of Date Conversition and selected MS SQL Min/Max option, but once i change the setting then i gets the below error for same process,“System.Data.SqlClient.SqlException (0x80131904): Execution Timeout Expired. The timeout period elapsed prior to completion of the operation or the server is not responding. ---> System.ComponentModel.Win32Exception (0x80004005): The wait operation timed out”(This error is geeting for those tables who has Date Column, and date column has such data (for example 03/01/2022 6:42 PM ) )What are steps to solve above error?
Hi all, I have an data source that gets daily refreshed in the ODX. With some tables, I have encountered the following error. Does anyone knows how I can resolve this? Thanks in advance!
While Running Transfering Task im getting error “Transfer Data from Data Sourse with Incremental Load”after appling incremenatl Load, again im getting Same error.
Hello, For two weeks my clients Power Bi report was refreshed daily without issues. Last week this changed after the TimeXtender Execution server stopped running. I ran the TimeXtender ODX Server Configuration on the desktop and started the TimeXtender execution server again. The next days the execution jobs where triggered again but I would like to know why TimeXtender Execution stopped running in the first place. How could this have happened?
This it’s the Snippet with the descriptions in the parameters: When I use the snippet, the description it’s missing:
After upgrade to the new version all the measure’s definition has disappears: I’ve send the issue to support.
Hi,Need help on the following : I have built the entire SSL model is built on Analysis server & want to understand what is the best practise around this? We have one base model built & users can access all the tables & can be confusing to the user which table & column to pick from. We have tables from Finance, Operations, production, Purchasing everything. How do you segregate & manage scenario like this? We did explore Row level security, but it is no good & we need to use Object level security which is not supported by TX.
In query table all tables are visible but while adding table in MDW(In select table option ) no tables are visible.
The column LVALUE from the table "PROD"."MICROSOFTDTPROPERTIES" failed synchronization with the error:System.Exception: Invalid data type long raw.how to solve this error.
Hi,our customer has a dimension table with a parent-child architecture he wants to use for RLS. The table looks something like this:cost_center, name, parent_cost_center1, management, NULL2, teamlead_1, 13, teamlead_2, 14, worker_1, 2In Power BI I would use the PATH() function to create the hierarchy as an additional column for every row (e.g. “1 | 2” for teamlead_1) and then use the PATHCONTAINS() function in the RLS settings to check, if the current user’s cost_center number is in the hierarchy column.I have not figured out how to implement this is TimeXtender. Does anybody have some experience on this topic?
I have a API endpoint with pagination:https://www.mytestserver,com/DWH/api/v1/all-buildings?buildingType=BAR&page=5I have created a RSD file with the following code after </api:info> <api:set attr="in.Header:Name#" value="Accept"/> <api:set attr="in.Header:Value#" value="application/json"/> <api:set attr="in.DataModel" value="FLATTENEDDOCUMENT"/> <api:set attr="in.JSONPath" value="$.data"/> <api:set attr="in.EnablePaging" value="TRUE"/> <api:set attr="in.Page" value="1"/> <api:set attr="in.PageCount" value="100"/> <api:set attr="in.BaseURI" value="https://www.mytestserver.com/DWH/api/v1/all-buildings?buildingType=BAR&page={page}" /> <api:set attr="in.ElementMapPath#" value="/json/meta/pagination/pages"/> <api:set attr="in.ElementMapName#" value="pages"/> <!-- The GET method corresponds to SELECT. Here you can override the default
I’ve read the artical Enum and page method but we still have a question how the json response and the RSD file should be.It would be great if anyone provide a full example (json response data and the RSD) so that we can fully test.Thanks for advance!
If you see Task are sucessfuly completed in ODX, and tables are vissile in query tool, but while loading data from ODX to MDW in select Table options tables are not visible, as shown in Figure
hi, Lately were are getting alot of 503 exceptions. Error message is typically: The task '983693' failed:System.AggregateException: One or more errors occurred. ---> System.AggregateException: One or more errors occurred. ---> System.Net.Http.HttpRequestException: Response status code does not indicate success: 503 (The server is busy.). at System.Net.Http.HttpResponseMessage.EnsureSuccessStatusCode() at Azure.Management.REST.RestWebRequestManager.<SendRequest>d__6.MoveNext()--- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw() at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at Azure.Management.REST.RestWebRequestManager.<SendRequest>d__5.MoveNext()--- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw() at System.Runtime.CompilerSe
Hello,we're using Timextender with ADF for the data movement between our Data Lake storage and SQL Database. Running the execute from TimeXtender of rerun it within ADF the performance is poor (slow!).Our setup at the moment, regarding to the specs within the topic "Create a Demo Template Project TX SaaS”. We wanted to start basic and then tweak the settings for better performance. Executing the first SQL DatabaseService tier: General Purpose Compute tier: Serverless Hardware: Standard (Gen5), Min/Max vCores 10 and 30GB Min/Max Memory Auto-pause delay: 1 hourIntegration Runtime - type AzureComputer Size: smallWe tried using a different Computer Size on the IR and also changed the SQL DB Tier for more DTU. No performance improvement after changing.Looking at one of the jobs we are transferring 2048 rows from our Data Lake to our Azure SQL.The Queue is taking most of the time. We did some research on the support page of TimeXtender (No topics) and also at the Microsoft community. Ther
We are having issues running source objects when source is CData BigQuery connector.Execution of objects run fine when executed individually with Deploy and Execute. When the objects are added to an execution package, the execution package runs fine when executed manually. But when the package is run on a schedule, the package just “hangs” and never finish the job. This prevents next running packages from executing, until we kill the process.When we look at the running processes on the machine, it seems like the Timextender package is running as a process. But if we look at the ongoing execution processes in SQL Server, nothing is running.The Event Viewer reports issues with “The application-specific permission settings do not grant Local Activation permission for the COM Server application” at the same time the process started.How can we fix this issue and ensure BigQuery objects can run as part of an execution package?
In v20 and before you can define multiple statements in a query tool window. This can be handy when doing comparisons or dealing with wide tables. v20 statement 1 v20 statement 2 In v21 the second statement is simply ignored for SQL DWH instances and results in an error in Snowflake:v21 SQLv21 Snowflake ; separating statements Was this taken out of v21 or should this actually work like in v20?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.