Ask questions and find answers about TimeXtender Data Integration and TimeXtender Classic desktop applications
Recently active
Hi all, I create a datatable from Json file with REST data source but got an error as below. ‘The bcp client received an invalid column length for column ID 1.’ Since the the column is zero based I look for the data in second column in my json file. I have ensured that the first and second columns are not read in the RSD file. However, the problem still persists. I believe the issue may be due to the data in this column being too large. This is API: https://archive-api.open-meteo.com/v1/archive?latitude=51.51&longitude=-0.13&start_date=2018-01-01&end_date=2023-04-15&models=best_match&daily=weathercode,temperature_2m_max,temperature_2m_min,temperature_2m_mean,apparent_temperature_max,apparent_temperature_min,sunrise,sunset,shortwave_radiation_sum,precipitation_sum,rain_sum,snowfall_sum,precipitation_hours,windspeed_10m_max,windgusts_10m_max,winddirection_10m_dominant,et0_fao_evapotranspiration&timezone=Europe%2FBerlin How can I solve this issue? Thank you
I would like to be able to flash fill down NULL values in my DSA table with certain conditions.In the table below I have multiple NULL values. Take for example the column ‘CardCode DUAL’.Row 2 with Company key MTW and project 1201121979 shows for CardCode DUAL DB0006. I would like to show value DB0006 also for all other rows where company key = MTW and project = 1201121969.Same for Route Bron column. I would like to fill down NULL values on the most recent NON Blank value for that Company_Key+Project combination.I think it should be possible with a self join or self select, but not sure how.
Hi community,we are facing the problem, that we create duplicates when we bring data from an ODX API source to the MDW. We are working with an overlapping sliding window of two days in the schema file (because data can change and there is no last modified date) and only set the primary key on the ODX source.In the MDW (dedicated SQL pool) we enabled the history and set the ID as natural key. All fields are marked as type 1 fields.The execution brings us duplicated ID values - no updates are madeThanks for your helpMichael
We are using Business unit to land our data in the DW. We have a few columns where we need to obfuscate some of the data.At what point should a script action be placed to update the field in the raw table prior to the data being moved into the valid table, so our script does not need to include an update to the field in both the raw and valid table. the script uses UPDATE table SET column
Hello,We have a data source that contains several additional/stacked connections in our Business Unit. We now wanted to add the 4th additional connection (so in total 5 data connections), but TimeXtender crashes when clicking on OK after configuring the connection. I think it tries to connect to the data source and get meta data for the tables it needs to select but somehow this fails. Found this in the Event Viewer: The errors are as follows:.NET = System.OutOfMemoryExceptoiin Application Error = Faulting application path: C:\Program Files\TimeXtender\TimeXtender 20.10.38.64\timeXtender.exe Faulting module path: C:\Windows\System32\KERNELBASE.dll Application Error = same as 2.)We are on version 20.10.38, do you have any idea what might be causing this? Why don't we get a proper error message in TX interface?Connection to the data source through SSMS is working without any issues by the way.Best regards,Kaj
I’ve got the following user request but I am not sure what the most optimal solution is, as i can think of many possibilities.I’ve got 2 Facts Tables:DSA.Fact_Turnover DSA.Fact_TransportOrdersBoth Facts contain the ‘Project’ column. The user request is to finally get the Turnover for all projects which are in Fact_TransportOrder. What is the most optimal way to get a check column to see if the Project value of Fact_TransportOrder is also present in Fact_Turnover and why? I want to use this filter column to eventually only present him the Turnover for projects which are also present in the Fact_TransportOrder.I’m really curious, as I already have such solutions, but am not sure if there are more easy TimeXtender functions or tricks which i’m not using currently.
After connecting successfully to my SQL server and adding the tables & rows I am able to preview the data by Select Tables. The Synchronize task also completed successfully. However, when I execute the Transfer task it fails with 2 errors (see attachments). I can’t figure out the reason why it fails though but the error message suggests something that (The specified path does not exist). I tried to remove the File Container in Azure and sync+transfer again, but it does’nt make a difference.
We have 2 jobsJob 1 runs at 11pm and normally runs 1 hour. Job 2 runs at 1am and must run after Job 1 completes, this job usually runs for 6 hours. On occasions Job 1 runs 3 hours and this causes job 2 to miss it start window. How can I adjust the schedule so that Job 2 has 2 criteria? 1-Job 1 completes 2-Has to start after 1am
Hi,We are using the Excel Online connector which is authenticated with a service account and uses delegated permissions to access Excel files on Sharepoint. The idea is that all relevant files will be shared with this account and then loaded into our DWH. The required files are visible on Sharepoint when siging in with the user:But for some reason, they are not when using the Excel Online connector (with option Show shared documents = ‘True’). I know that the connector uses the /SharedWithMe (OneDrive) call to fetch shared items, since that is what I inferred from the logging.This call indeed retrieves no results through the Graph Explorer, but the files are visible through another, similar, call on the Graph Explorer (the one from ‘Insights’): Why are files visible on Sharepoint but not on OneDrive? Is there a way to work around this? I have seen use cases where they actually are visible on both Sharepoint and OneDrive and the connector is working properly.
TX: 20.10.39ODX: 20.10.37ODX Storage: SQL Server DB on-premDSA/MDW: SQL Server DB on-prem We are successfully able to connect to a DB2 system and synchronize, we can also successfully use the Data Source Explorer to query tables. Every table we try to extract fails with the following error (schema/table/column names obfuscated): Executing table [schema].[table]:failed with error:edo220W.gm: The column [column] does not exist at edo220W.ai.GetOrdinal(String ) at System.Data.CData.DB2.DB2DataReader.GetOrdinal(String name) at System.Data.SqlClient.SqlBulkCopy.WriteRowSourceToServerCommon(Int32 columnCount) at System.Data.SqlClient.SqlBulkCopy.WriteRowSourceToServerAsync(Int32 columnCount, CancellationToken ctoken) at System.Data.SqlClient.SqlBulkCopy.WriteToServer(IDataReader reader) at DataStorageEngine.SQL.SQLStorageEngine.TransferWithBulkCopy(SqlCommand destinationCommand, String destinationTableName, IEnumerable`1 columnModels, IDbCommand transferCommand, DataTable transfe
Is it possible to connect to an Amazon Timestream database (https://aws.amazon.com/timestream/) with the ODX?
I am trying to get data using REST API Data Source: ODXProvider: CData 2022Authentication: OAuthFormat: JSONOAuth Grant Type: ClientAuthorize OAuth SuccessfulTest Connection getting below error: RSSBus.RSBException.HTTP Protocol error. 400 bad requests
Hi,We are currently migrating cubes from Power BI report Server ( On-premises) to Power Bi premium.Those cubes are not maintained in TX & refreshes are triggered through a SSIS package called by TX at the end of the ETL execution process.In the new implementation (where the tabular models are still not maintained in TX), we will be using XMLA endpoints & would like to trigger partitions refresh from within TX without using a SSIS package.What would be the best approach to tackle this, taking into account we’re running on an Azure platform (so TX VM and Azure SQL DB for DWH) ?We were thinking of using an ADF pipeline or use REST api calls, but this isn’t supported by TX version 20.10.x. Any ideas on possible alternatives ? ThanksPeter
Dear Support,I'm running into a weird error when I try to load customer data from the customer table of Navision. The error is: The numerical value is too large to fit into a 96 bit decimal.I use a query table to only get the columns I need. In this query table I use a where clause in which I exclude some customernumbers. But now I found out that I also need these numbers in my customer dimension. But when I clear the WHERE clause, the error comes up again.If I execute the same query in SQL Management studio it runs good and I don't see some strange values in one of the columns.Do you have any idea?
Hi I am just testing our V21. I have started with something simple, a 2 column CSV file with an integer key field and a text group code field. There are 18 rows.I can load it into the ODX fine (running on local SQL Server db) and I can preview the contents in the ODX “Select Tables” Pane.I can drag it to a Data Warehouse Data Area and it creates and maps the table fine with appropriate field settings.When I deploy the table in the Data Area that works fine.When Executing I get an error on the transfer which does not tell me what is happening. The error I get returned is as follows: Transfer table failedDetails:Transfer table failedModule: timeXtenderSystem.Exception at TimeXtender.DataManager.StepTransferExecute.DoDataWarehouse(IStepSetup stepSetup, List`1 mergeODXTransferInfromation, VariableResolveObject dynamicResolveObject) at TimeXtender.DataManager.StepTransferExecute.DoAbstractStep(IStepSetup stepSetup) That means nothing to me and I cannot determine what I can do to correct
I am curious why system fields like SCD is Current & SCD is TombStone are datatype bigint. Is there a way to change them to tinyint? As far as I know they can only be 0 or 1.
I am setting up a table relation where the tables join based on a date range (see screenshot below)In setting this up in TimeXtender, I noticed that I can only set this up on the lookup field and not as the default relation between the tables.Does anyone know of a way this can be setup on the default table relation? Or can we had as an enhancement for TX?(NOTE: I have edited the table names and columns for this post)
In my DSA I have my Business Partner Master Data. I want to add a field that named Intercompany that shows ‘Intercompany’ when BP Group Code = 104 or 109 and else show Extern. BP Group Code has a smallint datatype. I added a custom field with the CASE WHEN statement. However, the extra field does not show the right results.When executing the CASE statements SMSS everything works fine, but when I implement it in my DSA, it does not work correctly.I tried all kinds of CASE statements with e.g. Like,OR statements, strings, however it does not show the desired result, but rather tons of nulls.The screenshot below shows the intercompany field with the Nulls and some tests CASE statements.
Hi all,Too many parameters in nasa api data available year and month. I changed their name via RSD file because and have only one table like below; I have to change this columns in this dataset from this station WS10_MAX201901 WS10_MAX201902 WS10_MAX201903 ….. WS10_MIN201901 WS10_MIN201902 WS10_MIN201903 …... to this station MM.YYYY WS_10_MAX WS_10_MIN How can I do it? I tried Custom Table Insert but doesnt work. I tried also Junk Dimension but I had to clone my dataset 12 time to be able to print for example 12 months 2019 data consecutively.
I'm following the steps explained on this page (https://legacysupport.timextender.com/hc/en-us/articles/360034695651-Connect-to-a-REST-API), but I can't figure out. Situtation: I have to get for all station weather data from DW. An example for stationnummer 10184 like this:https://s3.eu-central-1.amazonaws.com/app-prod-static.warnwetter.de/v16/forecast_mosmix_10184.json You can find the all station list here: https://www.dwd.de/DE/leistungen/met_verfahren_mosmix/mosmix_stationskatalog.cfg?view=nasPublication&nn=16102 What I did?first I set up a dataset for the sample station 10184 and got the ‘days.rsd’ file. Then I made some changes in ‘days_changed’ file(it doesnt work). And I coudnt generate it.
When associating instances to an Execution Server in 6221.1 I noticed that the message displaying locked instances has a slight grammar mistake: “The following instances that currently locked by another machine” should probably be something like “The following instances are currently locked by another machine”.
Hi community,I have a client attempting to load a postgres database into ODX Server (TX version 20.10.x). The table contains a field with dates that are invalid for SQL but valid in Postgres, for example 20011/01/01. Upon transfer, the task completes with errors that it is unable to parse datetime value. All datetime fields have been converted to VARCHAR(MAX) using Override Datatypes and this is confirmed by looking in the ODX Storage in SQL Server Management studio. Since the error still presents itself, it seems likely that the error is coming a step earlier, during the CDATA conversion. Unfortunately, it seems that there is no way to generate RSD/schema files from the CDATA Postgres provider. Normally I would change the datatype there in these situations, since it seems to be going wrong in CDATA somewhere. How can I load this table? Kind regards,Andrew - E-mergo
Currently it’s not possible to create a job to concatenate the transfer task of data source (d365 f&o) to ODX and from this to DSA.I would need to get the age of the data in ODX to transfer that value to somewhere in DSAHow can I do this?
While running trials of TimeXtender it is fairly common to run against SQL Server Developer Edition. As SQL Server 2022 has been GA since last November, this is the version people will generally be installing.Finding 2019 is fairly hard. I have noticed that the 20.10.37 ODX Server is perfectly happy, but that TimeXtender 20.10.39 gave me an “Unsupported version of SQL” error, even with databases running in SQL 2019 compatibility level. Is this supposed to be the case?Azure SQL DB is 2022 under the hood, even if SELECT @@VERSION states something else.
When I opened the project today ODX showed this error.Another ODX service has the lock to the project. Please run the configuration tool to take over the lock.What could it be the reason?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.