Ask questions and find answers about TimeXtender Data Integration and TimeXtender Classic desktop applications
Recently active
Dear Support,TimeXtender version: 20.10.43.64In TimeXtender we have two project variables that we use in a data selection rule in a semantic model.In attachment "project variables settings” you'll see the settings of the two variables.The dynamic variable script that it has to execute is:SELECT CAST(MAX(LoadingDate) AS DATE) FROM FinFact.FacturatieControle to get the highest date. The other script will get the lowest date.In attachment "semantic model with data selection rule” you'll see the data selection rule in the semantic model. We want to filter the date dimension so that it only shows the dates which are in the fact table (FacturatieControle is the fact table).The problem now is that the project variable won't update although we set the resolve type at 'Every time’.Only a deploy and execute of the model will update the date filter. Can you help me with this issue? Best regards,Christian Koeken
Shortly we will be implementing Tableau endpoints with TimeXtender. With respect to RLS, I read the following in the ‘Semantic Model-Level and Row-Level Security’ tutorial:Is it on the roadmap for TX to implement RLS on Tableau endpoints as well?Maybe you can elaborate on the mechanism behind the .tds endpoints, do these need RLS like you can configure in Tableau (i.e. by configuring something on the semantic model in TX which is currently unavailable)? Or do they use a connection to the DWH (SQL db), thus using the permissions on tables related to the users of the dashboards?
Hi all,I recently created a bunch of SQL logins in TimeXtender to use in our Database Roles we set. After I did that I found out I made a mistake and I removed those SQL logins from the database. However, when I try to edit a database role and try to Add a login, I still see the SQL logins I removed.To make sure there is nog caching or something involved I waited a few days before checking if they were still there.Does someone have a solution to remove those logins from the list? I don't want to create new names for my SQL logins just to avoid having the same name as the previous one. Although, if that is the only option I am willing to accept that as well. Kind regards,Carlo
Hi all,what’s best practice regarding organizing/reusing measures in SSLs?In my example the customers uses a power bi endpoint and has created a set of measures used by users in power bi. Lets say these are financial measures. A few question regarding best pratice have now popped up:We want to reuse these measures in a different SSL. For example we have SSL for the financial department and one for the board of managers. We don’t want to duplicate the measures, because it makes it hard to keep them up to date. Is there a way to “copy” measures from one SSL to another or to reference measures from a different SSL? We want to “categorize” the measures. So lets say we have financial measures as well as logistics measures. Once we get to a significant amuount of measures, it’s hard to keep track of them. Is there a way to prefix them, add categories of something similar? We had the idea of creating empty “measure” tables in the MDW with a separate “Measure”-Database-Schema. But this also c
Hi,I am trying to connect to a REST API that uses OAuth2 authentication.The API documentation is very clear on what to include in the authentication: I have entered all this information in the REST CData provider and I can successfully use the provider’s “Authorize OAuth” button.However, when I try to test the connection, error “401 - Unauthorizated” is returned.In the API documentation, they state that the token needs a prefix “Bearer “.I suspect my error is caused by the REST CData provider sending the authorization header without the Bearer prefix, like so:Authorization: {ACCESS_TOKEN}Which the API of course does not accept. Is there any way to include a prefix to the token in the authorization header?
Hi all, We ran into an issue with history settings in combination with the DW_SourceCode. We need the DW_SourceCode in our primary key as there is overlap in the sources and this ensures uniqueness. In the history settings we cannot choose the DW_SourceCode to be the natural key: Without this, history does seem to work, but when we enable Create new record when a deleted record reappears in the source We obtain the error Error during Data Processing for Table: Maintenance.Verkoopinfo at: MaintenanceThe column name 'DW_SourceCode' is specified more than once in the SET clause or column list of an INSERT. A column cannot be assigned more than one value in the same clause. Modify the clause to make sure that a column is updated only once. If this statement updates or inserts columns into a view, column aliasing can conceal the duplication in your code.I've looked into the stored procedure that produces this error and this snippet produces the error: -- History: handle deleted records IN
Hi, can you provide me with detailed instructions on how to set it up?
When configuring the CData Microsoft Sharepoint (23.0.8669) provider for extracting a Sharepoint List, we encounter a problem with the button ‘Authorize OAuth’. We are configuring the data source in ODX Server 20.10.40 and TX version is also 20.10.40.The following settings are configured:According to the CData documentation AzureAD should be used as Auth Scheme to leverage OAuth to authenticate, we also use this exact same setting and the same app registration for another data source using the Excel Online provider for which all is ok.However, when using ‘Authorize OAuth’ with the Sharepoint provided, we get the following error:What could be causing this? Changing the file or location for OAuth does not matter at all, we have also tried other versions of the provider but they all give this error. Also, changing Initiate OAuth to ‘REFRESH’ does not have an effect.
HelloI need the creation date and time (createdAt) of a CSV file within the MDW table as a column. How can I access this information?Best Regards
In order to retrieve meteorological data from The Netherlands, we want to use the Open Data API developed by the Dutch Meteorological Institute (KNMI). This website contains all relevant information on using the API.In summary, these are the steps that we want to undertake. Anyone can do this, because of the anonymous API key that is open to public:Locate the ‘Anonymous API key’, can be found on the KNMI documentation website Determine the dataset name, version and filename to establish the correct endpoint In this example we want to use the following endpoint: https://api.dataplatform.knmi.nl/open-data/v1/datasets/etmaalgegevensKNMIstations/versions/1/files/KIS___OPER_P___OBS_____L2.nc/url Execute the GET call (make sure to use Authorization header in combination with the anonymous API key The GET call returns a download URL pointing to the KNMI Amazone AWS storage which can be easily used in Postman to retrieve the data (in x-netcdf format)Would you like to try the above in Postman a
Our ODX is hosted on a separate VM in Azure. We followed the suggestion to use the size DS2_v2, but we encountered frequent “System Out of Memory exception was thrown” errors that caused the ODX to stop. We are planning to switch to E2_ads_v5, which has twice the memory, but I am curious if anyone else has faced this issue and has any advice.
Dear Support,My customer is having some troubles with executing a tabular semantic model. This customer has three semantic models, Finance, Sales and Logistics. Finance and Sales are running fine, but Logistics sometimes give the error "The stream does not have an active operation!”.I solve this issue by doing a Full process on the model in SQL Management Studio. But what I want to know is what causes this error? As I said Finance and Sales are running fine, but Logistics gives this error now and then.See the file in the attachment for the error. TimeXtender version: 6346.1
We have created several jobs on our ODX and several jobs on our DataWarehouse. The ODX jobs are running correctly based on schedule, but the Datawarehouse jobs never run since there is a schedule.We've also deployed and saved our project, so that should not be the problem.
Hello,Is there any posibility to know how much data was loaded through the data warehouse during a scheduled execution package? Either through TX repository, logs or through system files in the azure database?Let’s say my customer has a databasewith 500gb worth of data, but we load only certain tables (some full, some incremental) and would like to know how much data we push every scheduled load.Thank you,Victor
When designing a model, in TX we have to options:Deploy. It deploy all the model to the server without data Execute. Reads the data from the DW and fills the model in the server.After we have the model in the server, we can use external tools like Tabular Editor or Power Bi in the service to add custom measures that it’s not possible in TX, for example calculation groups (see video from @fwagner :Until here, all ok. The problem appears wen you Execute the model again from TX that deletes all the external changes.In think that it’s an issue.
Hi,I am running a legacy version of TimeXtender (version 20.10.40.64), where we have an Excel Online connection set up using CData ADO.NET Provider for Microsoft Excel Online 2022 (22.0.8389.0) as data source.This data source is configured to authenticate via Azure ‘client flow’, see picture. The app registration in Azure has the following permissions: The data source works properly most of the time. It is able to list the worksheets it finds on the SharePoint site, and can fetch data. However, scheduled execution packages sometimes fails with the following error message:[500] Could not execute the specified command: Error while listing workbooks for drive: [generalException] General exception while processing. Details: Error while listing workbooks for drive: [generalException] General exception while processing. Module: System.Data.CData.ExcelOnline fx220l.yg at fx220l.IIu.m(Boolean ) at fx220l.IIu.X(tbp`1 , Boolean ) at fx220l.IIu.YI(LoL )
I have a table with a varchar(max) field (stored in Dedicated Pool, which is a data source). and it won’t come through to ADLS Gen2 (ODX, version 6284.1). I’m using the Azure Synapse provider.The longest field contains almost 4 million characters, but I’ve been unable to figure out whether this is a limitation in TX or Azure. Does anyone know?
Hi!I beg your pardon for this somewhat lengthy post, but I try to be thorough to avoid confusion. :)I have a problem with updating an SCD.We are moving an old adress history table from another system into a SCD in TX. It has gone well so far since the old system made one insert per person per day regardless of whether there was an update or not, which has made us go from about 108M rows to about 275k rows with actual changes. So far so good. :)The problem now is that have a hard time to get this moved table to update correctly from a new source. The setup looks like this at the moment: The MDW table KIR_Persons is the correct and prepared historical data from the old system where I have fixed the From- and To-dates along with the “Is Current” flag. The “break date” for the data from the old system is 2023-10-16 which is when I made the final export.The new source for the address data is the DSA table KI0VAA0POPULATIONPERSON_QT which is the result of a query table. I’m using the DSA vie
HiIn one of my projects, I created a model by transferring the table I received from DSA to MDW using view. When I wanted to create the relation diagram of this model, I saw that it could not establish a connection with the view and DSA table. How do I ensure the connection of all tables at the end of the project? There is no problem with Data Linage.Best Regards
Hello to the community 😀 Currently I started the TimeXtender Training. I am at the point where I have to create the instances. Adding the ODX or SSL instance was no problem. But adding the MDW instance didn’t work out for me. The problem is that i can’t select any storage in the “Server storage type” field. It just says “No items found”. (While adding the ODX instance it preselects “Azure Data Lake” and I can just switch to SQL database”, but while adding the MDW instance it doesn’t give me these options) Does this problem occur to anyone else? Do I maybe have to change any configuration before the “add data warehouse step”? Thank you in advance. Kind regards,Tobias
When we create a custom measure:TX qualifies the measure with the table name and this it’s not a good practice. It it’s the oposite that I comented in: FYI: @fwagner
We use Sharepoint for multiple data sources. Connecting the Sharepoint Lists works fine and I have a OAuth for Excel Online running as well, but my data source throws an error: Cannot find file. I need to handle multiple files according to this documentation:https://support.timextender.com/data%2Dsources%2D112/connect%2Dto%2Dexcel%2Dfiles%2Dwith%2Dexcel%2Donline%2D628 What’s the reason for this? My App Permissions are set accordingly: My Setup looks like this:
Hi,In my DSA layer I succesfully added a mapping set for which the include rule has identifed two tables. All of the columns in my DSA table have been renamed so none of them align with the original names in the ODX. As a result, the mapping set tells me all of the columns are missing: This specific table was first added to the DSA for a single ODX table, then the columns got renamed and at a later moment I wanted to replace the mapping to a mapping set. Should the mapping set be able to cope with this? In essence, it would be just like doing it manually and using the ‘smart synchronize’ option. But the mapping set does not seem to work like that.Best regards,Kaj
Hello community, Is it possible to do RegEx with TimeXtender? Or use Python code somewhere in TX that supports the library re? Our business case:- We have a database with text reviews of varying lengths, where personal information is sometimes available. We want to read the database in and anonimise the values which contain personally identifiable information. For example: "oh no, ZuzaGlog doesn't know how TimeXtender works” and we want to make it "oh no, XXXXXX doesn't know how TimeXtender works”. We currently do it in Python with the library re, and a list of possible personally identifiable information. We search through the strings with reviews using the keywords from the list, and replace hits with XXXXXX. Now we want to build this solution in TimeXtender. In what way would this be possible?
Our client has a question about a historical table in TimeXtender. They would like to know if they can make a onetime update from SSMS to populate historical records. More details on the scenario below.Scenario:Table in question is in MDW An ID merge has been done to collapse users that have created multiple accounts into on true account. Logic is done in DSA and flows to MDW. The new merged id was inserted as a new field in the MDW table, the old id was renamed. New merged id field is null for historical records where old id is populated. This makes historical queries fail.Question: Can they run a one time stored procedure in SSMS to fill in the historical records to the new merged id field? What are the potential drawbacks of this solution?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.