Ask questions and find answers about TimeXtender Data Integration and TimeXtender Classic desktop applications
Recently active
After attempting to add a new column to my history table, I cannot get the table deployed and executed anymore. The new column is currently not in the table, but I also can't get it to get back to "old" historical table back without the new column. Currently have tried the following things, but so far without result:Set the project version back to an earlier version where the change wasn’t made yet; Upgrarde the PROD SQL DB Size and deploy again.It does not get beyond the Valid Table structure when deploying the historical table. When previewing I also get the following error messages:The table you are trying to preview has not been deployed yet. Deploy first.Invalid column name 'SCD Type I Hash Key'. The table you are trying to preview has not been deployed yet. Deploy first. Invalid column name 'SCD Type I Hash Key'. Details: SQL Server: 'c5d03ed4f0ca.tr30953.westeurope1-a.worker.database.windows.net,11052'SQL Procedure: ''SQL Line Number: 1SQL Error Number: 207 Invalid column name
We are planning to use Export to Azure Data Lake feature in D365 F&OMy question it’s:How can connect to the Data Lake from TX?Or, we can connect to Synapse Analytics?How can we make the data source setup in TX?
I have the following code y DSA:Select * from TableA union Select * from TableBunion Select * from Table CI want to replace this code with a table
We have a SFTP source on which CSV files are stored and which can be authenticated to with a ‘public key’. When using the CData SFTP-connector in ODX Server, we are able to connect with the following settings: The most important setting here is the SSH Auth mode, where we specify that we are using PublicKey authentication. Since I am not familiar with this type of connector, I would not now how to retrieve the data from the CSV files (the only table we get from the source now is the ‘Root’ table that contains the FileNames that can be found in the folder).I would rather use the CData CSV-connector, but that leaves me with a problem when testing the connection: I cannot specify that I want to use the PublicKey authentication mode. That is, it is specified under ‘SSH Auth Mode’ but it is not possible to select under ‘Auth Scheme’: As a result, we keep getting the same error on testing the connection (see attached file). I have tried setting the Auth Scheme to ‘None’, ‘Auto’, ‘SFTP’ or ‘B
Hi,We are receiving some weird error messages when executing our project, which uses Azure Data Factory to copy tables from our Data Lake storage to the Azure SQL db (ODX → DWH). The error can be found in the attachments. When inspecting the pipeline run on ADF, it seems to be missing the configured activities (see second attachment). When executing the table manually from TX, the pipeline runs succesfully. Also the pipeline seems correctly configured on ADF and the pipeline run that is created when executing the table manually shows the correct activities.Any ideas as to what might be causing this? Best regards,Kaj
I’ve three excel files in a SharePoint folder:Budget Forecast Price ListWhat it’s the best option to get the files into a TXA DSA?Can you provide me with detailed instructions?
We are seeing a situation where the next scheduled execution of a package does not start and the event is logged that this is because the previous execution is still running. However, when we closely look at finish times for these executions, the actual finish time is on average 8 minutes before the start of the next execution. I've been told that there can be a delay of a couple of minutes between the task itself actually finishing and the moment the process that executed the task is ended as well. However, 8 minutes and sometimes even up to 13 minutes seems too long.Anybody any ideas on why this occurs and what could be done about it? We're currently running TX version 20.10.25.
Can you explain how and for what it can be used?
Can you provide some documentation about this?How can I use it?For what it must be used?
Hi,The current Data warehouse has tables with two different DB schema's. There are already PowerBI Dash-boards using these schema's. Now I want to use the Semantic layer to copy the data (Data Export) to a SQL serverless DB. Everything works fine but I want to override the schema name. In the Semantic layer I have not find any options to change this. Is that correct or is there a way like in the Dataware house layer to change the schema?
TX: 20.10.39SQL Server: 2019Endpoint settings:Windows authentication hostname matching case https connection over the default proxy I am trying to push a Qlik Sense Enterprise endpoint from TimeXtender and having trouble getting the deploy successfully running. Testing connection to Qlik Sense is successful, when I Deploy I get an error when TX tries to create a new Data Connection. I see this issue pop up sometimes in other deployments and can usually overcome by manually making a Data Connection to the MDW database and giving it the same name TX would use: MDW_SLQV . In this case, I get the same error when TX tries to modify the connection.TimeXtender does create the app (and is owner of it) and can successfully reload the app, it just doesn't insert the script. If I copy-paste the TX Qlik Script into the app it works fine. As neither TX nor Qlik actually log what is going on, I cannot see what about the connection string is causing the error.
When you arte coping between instances, the destination insatance name doesn’t show complete.
As you can see in the screenshot, I think that this situation must be controled:
v20.10.36.64Hi,I have a project that is loading data from the ledger table into the staging database with approx, 5m records.When manually executing the load, the ADO.NET transfer is taking 5-6 minutes, but the cleansing rules can take hours, to the point I have to terminate the load.Is there any troubleshooting I can perform on the cleansing steps? I know I have taken the easy option on joins where the data types differ, and wonder if that is now compounding the issue?Any tips or pointers greatly appreciated.Thanks,Richard
Hi,I would like to do a “range lookup”. Because I can't solve it using a conditional lookup, I used a custom field transformation. My code looks like this:CASE WHEN substring([SBIcode_cleansed], 1, 1) like '[^0-9]' THEN (SELECT [kvk_groep_omschrijving] FROM [dsa].[SBIcode_groepering] where [SBIcode] = [SBIcode_cleansed] ) --'test1' ELSE (SELECT [kvk_groep_omschrijving] FROM [dsa].[SBIcode_groepering] where substring([SBIcode_cleansed], 1, 2) >= [min_sbi_code] and substring([SBIcode_cleansed], 1, 2) <= [max_sbi_code] )--'test2' END It seems that a subquery is not possible because I get an error message that more than one value is retrieved using the subquery but that is not possible.Testing it in SSMS works fine. (Not using between because above seems to work faster when testing
Until I have started using TX, I am setting up my PBI import datasets using incremental update as you can see in:https://learn.microsoft.com/en-us/power-bi/connect-data/incremental-refresh-overviewNow, in TX, how can this be accomplished?
If you add a new field with the deploy only option, to an existing table with data, there are two diferent behaviors, depending if the table has incremental rule defined or not.This is controled by this setting: By default it’s cleared for “normal” tables and setted to incremental tables.I think the behavior should always be the same or at least get a warning message
I’ve detected that if you have the same table in DSA and MDW. let say DSA.Invoices and MDW.Invoices for example, and you define partition for that, both tables share the same partition schemas and partition functions in the SQL Server database.It’s a problem when you try to add or remove field from whatever table.
When I launch a job directly with the Execute menu option, I get several lines in the execution log without information to know what it is.
I have created a CSV source in Timextender NG ODX. The data explorer shows the data type correctly for my table.However, when I drag the table to the DSA, all fields appear as bigint type. (by the way, I have setQuote Character to “ and Row Scan Depth to 0). Any help on how to resolve this issue, would be appreciated.
I discovered that when using the replace transformation with the CharType that you are required to know or look up the int value of the character you want to replace and use that as the parameter.This does not seem to be documented anywhere or be useful in any way I can think of. I assume REPLACE('abc’, char(65), 'b’) is functionally equivalent to REPLACE('abc’, 'a’, 'b’). In a Case Insensitive collation there is no difference between the two anyhow.There is also no COLLATION or binary type support, which are things that you can do with REPLACE() that might actually be useful in certain rare cases.
I’ve created a custom field in a semantic model table: But in PBI using a Mixed storage model, it doesn’t works, but if I create the column directly in PBI desktop, it works:
Hi!We have had our installation for a while now but as far as I’m aware the application has the latest updates. As we are becoming more people in the project working at the same time I have installed the client on both a new server and on my own laptop. The problem is that when I try to connect to the ODX service running on one of our “old” servers I keep getting the error as in the attached pictures. Why is this? As you can see the application has the same version on both thte “old” and the “new” server.The correct ports are opened between the servers at least so that should not be an issue but I get the same error when trying to connect from my laptop. Anyone who has an input on this?
I’ve a query table created to my D365 F&O data source like you can see in this screenshot: The query returns data as you can see in the query tool (it would be nice to be able to run it in the “Manage Query Tables” window too): But, If try to Synchronize ODX Objects: I get an error and there is not the table if I try to remap it: And when I deploy and execute the table, it’s empty: Is this a bug or I’m doing something wrong?
Something it’s missing in this phrase:
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.