Ask questions and find answers about TimeXtender Data Integration and TimeXtender Classic desktop applications
Recently active
Hi, I am trying to conect to an endpoint using a dynamic query parameter from a simple SQL query: SELECT [CODE_ID] as codeId FROM [dsa].[Products]I use {codeId} as value in the query parameter. When deploying, I get the following error: Format of the initialization string does not conform to specification starting at index 0. When I hard-code the codeId, it works. Using this query does not work. There are around 600 codeId's in the query. Even when i limit it to 2 id's, it gives me the same error. My API documentation does not mention anything about extra parameters. Also, the logs do not give me much more information, other than the error I mentioned. Anyone has experience with this error and has a possible solution? Kind regards,René
Hi,We are trying to access ODX execution history (backlog / queue / duration / errors) for log analytics purposes.We understand from documentation and release notes that the local ODX backlog (Backlog.sqlite) has been removed / moved in newer ODX versions, and that execution metadata is now handled differently.However, we are currently unable to locate where this information can be accessed programmatically.Additionally, in the TimeXtender Portal, we do not see the menu optionAdmin → Security / Permissions, so we are unable to: verify roles/permissions access or inspect the API for execution data Could you please help clarify: Where ODX execution history (status, start/end time, duration, errors) is stored in newer ODX versions Whether this data is accessible via: the TimeXtender Repository database, and if so, which tables/views are recommended the TimeXtender API, and what permissions are required Why Admin → Security / Permissions is not visible in our portal, and wha
Hi All,My current employer uses a DWH with a lot of views (with unions and so on), which leads to slow execution packages. I would like to enhance the performance (rebuilding the views is one thing). But i woud also like to enhance the performance with indexing. So i have setup up one of our Dimension tables as seen below:Is our SupernaturalKey (SNK) Are our PK'sWhat would you guys recommend? Which type of indexing for SNK (nonclustered, unique index, Columnstore Index, Clusttered ColumnStore Index)?Which type of index do you recommend for PK's (nonclustered, unique index, Columnstore Index, Clusttered ColumnStore Index) ? Which type of indexing SNK and PK in fact tables?
Hello, Three of my collegueas where developing in our dev enviroment. And when trying to save the project, we got the error:An error occurred while saving the project to the database.An item with the same key has already been added.Detailed error:An error occurred while saving the project to the database.Er is al een item met dezelfde sleutel toegevoegd.Details:Er is al een item met dezelfde sleutel toegevoegd.Module: mscorlibSystem.ArgumentExceptionbij System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)bij System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)bij TimeXtender.DataManager.ProjectPerspective.AddProjectPerspectiveItem(ProjectPerspectiveItemsRow itemRow)bij TimeXtender.DataManager.Project.InitProject(Int32 version, DsProject loadDsProject, DataSet adaptersDataSet, ProjectsRow projectRow)bij TimeXtender.DataManager.Project.LoadProject(DsProject _dsProject)bij TimeXtender.DataManager.Project.<>c__DisplayClass136_0.<Load
Hi All,In TX 20.10.45.64 we would like to work with Work Items to prefent Project Locks. There is no option to Release the work item and make it green. I already tried:Deploy Execut Save and Reload the projectWe only have the option to update, edit or delete the workitem. How do we release these items and make them green?
Hi team I was recently working on a table where I added a hash field and configured it for incremental loading. However, the initial deployment failed because the table was missing the required column for the incremental process. When I attempted to redeploy to fix it, I hit a roadblock: a duplicate key error in dbo.DataFields with the value (ea41fe97-e408-4504-9164-239dfcdee390, 148, 99999999).
Hi,I have a customer working with TimeXtender 7150.1 connected to Snowflake.I have a .csv data-source connected through the Ingest. The ingest settings have a number of header rows removed. But in the data received, I have Totaal-rows that I want to skip or filter out.The option to “filter rows” by right-clicking the data-source in the Ingest area is not available for this source: My next option would be to add a data selection rule to the table connected to the ingestion. But that has no effect: my result table has two rows (one from each .csv source) with Totaal.The above data selection rule seems not to be used. The only thing I can do to get it working, as far as I am aware, is to manually add a line of code, using the “Custom Code” option:But I was told / had learned that using the data selection rule, would automatically change the transformation script.I am not a fan of this solution, as it is not immediately clear to a new user (or to me in a year time) that I have changed the
Hi team, I am encountering a timeout issue when moving large tables. The problem seems to be originating from the cleanup stored procedure (clean sp), as smaller tables are processed without incident. Could you please look into this issue?
I’m migrating a large SQL Dedicated Pool data warehouse to Fabric Lakehouse.I’ve run into Fabric’s workspace limit of a thousand items.What’s the best-practices workaround?
Hi TX Support, We're encountering a strange issue. We've setup an deliver instance of the REST API endpoint type. The model contains a dimension table. In the MDW layer this table contains 7844 records. Now when we pull the data from the REST endpoint we get 7844 as well, however the content is incorrect. Instead of the 7844 individual records we get 6974 records, 870 of those are duplicated and consequently 870 other records are missing. Example:DIM_Location TableLocation, Code, DW_Id Original MDW data LocationA, 123, 1LocationB, 345, 2LocationC, 678, 3 REST dataLocationA, 123, 1LocationB, 345, 2LocationB, 345, 2Missing Record in the REST dataLocationC, 678, 3Now I did tried everything I could think of in terms of troubleshooting. Everything is deployed, executed, refreshed and running. Going through the data I made an important observation. The set that is duplicated all are records that reside on the first page. They are then duplicated across the remaining pages. See the screenshot
Hi all,I'm working in TimeXtender (TDI) and ran into something I can't quite figure out. When I create a new schema in my Prepare instance, I want to assign it to a table that already exists in that same instance. The schema does appear as an option when I try to link it to the table. However, it gives an error upon deployment (of that table), at least until after I deploy the instance. Is this expected behavior?Or am I perhaps creating them in the wrong order or place?
Hello,I have a question about the RAW tables in TimeXtender. I noticed that the data types of the fields in the RAW table change when I modify them in the tool. I was under the impression that RAW tables should keep the original data types from the source, since this would be “RAW”.I ran into trouble when loading transferring from the ODX. I changed the datatype of a field and even added a transformation that resulted in a CAST in the transformation view. However, I got an error message saying: The given value of type String from the data source cannot be converted to type float of the specified target column.This should not be, because the source contains only data that is/should be convertible to a float. The Raw table has no data, which I find strange. Changing the fields data type to float has also changed the datatype of the Raw table. I would expect the Raw table to always have the same datatype as the source and that the changing of datatypes is handled in the transformation vie
I have an issue, and i have not been able to identify if this is a TX issue or a DWH issue.This is how TX is set up:I have a MS PowerApp that writes to the APP database.I can see that the records are in the DWH, like in the table below. I have confirmed that the entetried are in APP-stack.At 07:30 in the morning, execution package runs, then this happens:Meaning, the DW_ID that were previously Bob’s and Marlen’s are now overwritten by Kim and Tom.There are no traced of DW_ID 101 and 103 being registrered by Bob and Marlen either in ODX or in DSA.I dont know if it happens before the execution job runs, during or after. I have been scratching my head for the past couple of weeks.
Hi community,I created a role in the MDW and added Grant permission on one specific database schema. This schema contains some tables and some Stored Procedures. This role need to be able to select data in the tables and execute the stored procedures. I created my Object Security Setup using these settings: When I login using SSMS (using the user in the role), I see the correct tables and I'm able to select data in the tables. But I'm not able to see the stored procedures. When I check the permissions on the ‘ExcelAddin’ database schema. Only the ‘select’ permission in granted. Is it possible to grant permission for ‘execute’ as well? Using TimeXtender?
Hi,I have a client that uses TDI 7026.1 and i need to install it on another computer, but on the web I can only find 7050.1. Any possibility to find the earlier version somewhere?/Leo
I’m getting a Lakehouse notebook execution timeout in v7142.1 after exactly 10 minutes.My connection and command timeouts in the TX portal are 1200 and 7200 seconds, respectively, for both Ingest and Prepare so that’s not the setting I need to change … and the workspace’s Spark timeout setting is 20 minutes so that’s also not the one.I’ve copied the relevant part of the error message below.Does anyone know how and where to increase the notebook timeout setting?(the Microsoft links aren’t that useful from a TDI perspective, I think) Start Time : 10/15/2025 2:23:08 PM End Time : 10/15/2025 2:37:01 PM on server: V171D008S -Execute Execution Package Default 'Failed' An error occurred while calling o5570.throwExceptionIfHave.: com.microsoft.spark.notebook.msutils.NotebookExecutionException: Timeout when exe cell - 15 in notebook TimeXtender_PrepareKOMBI_TABLE_dsa_INVENTTRANS, code length = 39808 and it costs 600.001s. You can set timeout parameter to mitigate the issue. Please check th
I am having issues with decimal numbers in my Power BI model created with TimeXtender XMLA endpoint (version 7026.1).No matter the precision of my datatype on SQL server it seems like all values are forced into a rounded 4 decimal size. Is there a setting hiding somewhere to prevent this behavior?Below are examples or test data to demonstrate the behavior.Inspecting the model with tabular editor it seems all decimal fields are stored as fixed decimal rather than the expected double Test data Result in Power BI
In my TimeXtender Data Integration (Ingest) instance, data sources seem to be listed alphabetically. I’d like to set a custom order instead. I tried drag-and-drop, but it didn’t work, and I don’t see any option in the portal to reorder them.Is there a way to change the display order (e.g. sort settings, or another workaround)?If this isn’t supported, a confirmation would also be helpful. Thanks! 😊
Need help with TimeXtender data transformation issue. We're pulling sales data from SQL Server but getting errors during the transform step. The source has decimal values but TimeXtender seems to be reading them as text.Also need to set up a simple incremental load based on ModifiedDate field. Should be 2-3 hours remote work to fix the data types and configure the incremental logic.Need working by Tuesday for our weekly data refresh.Please Contact Me Asap.
Hello,Is it possible to Extract data from an existing Lakehouse into a Prepare instance without needing to move it into the TimeXtender Ingest instance? The use case is to avoid replicating the data again, if the customer has already ingested data into a data lake or Lakehouse.Thanks in advanceTim
Hi, When trying to replicate the use of “Importing OpenAPI” from this TimeXtender Tuesdays video i get bellow Time Out error: I am wondering if i am doing something wrong, or one could replicate this issue aswell.Regards,Devin
Hi,TDI ver 7026.1TimeXtender Ingest Service Configuration 7017.1 We are using Azure Datalake Gen2 Storage Container as our Ingest instance. I have set a load job (incr_load) from a sql server database to the ingest instance.This works fine during the day. When get into the next day the same job does a full load on my tables in the database. Why is this happening? I really need to solve this asap :-) regards,Bjørn A.
I have two tables with no unique identifer. There a two posts that mentions NEWID() as a way to create a unique identifier, so it seems that it can be used:How to add a default value to a unique identifier field – TimeXtender SupportHow to Add a Default Value to a Unique Identifier Field in TimeXtender Classic | CommunityI have created a filed in each of my table and made it Primary Key.My question is:What happens if we Deoply and Execute on DSA table with a column that creats uniqe id with NEWID()? Does it create new IDs that are different, or does the table keep the IDs generated before?
We are using the provider Azure Data Factory - SQL Server for a lof connections where the instances for these connections contains almost the same data but each time another customer. What we have noticed when the incremental load is setup to look at a datetime field called DW_MODIFIED_date. it will never load that 1 record which is in the table. When I exclude that table from the incremental load then I have 1 record loaded.When I include the table again in the incremental load it is removing the first folder from the previous load and don’t write a new file because it was not updated.When I remove the folder from the container and I incremental load that client table again I get no record at al while it should be the first load. Even if the incremental load is on and there is no file then I expect to have in the initial load the data.
I’m planning to change a history table in DSA into an incremental table without removing the history and I want to make sure that I understand some of the settings correctly. The ideal outcome for me is the following:New data added incrementally without the history being maintained Regarding the old history: I want to keep all rows with [SCD Is Current]=1 I don’t want to keep rows with [SCD Is Current]=0 Here are some questions I have about options in Table Settings > Data extraction :Does it make sense for this scenario to have the boxes checked for “Truncate raw table before transfer” and “Empty raw table after data cleansing”? What is the best approach for me to take with the delete options (“Don’t handle deletes”, “Use soft deletes” and “Use hard deletes”)? If I’m fine with new rows being overwritten can I then create some kind of incremental rule to make sure that old history is changed (or at least not for [SCD Is Current]=1)?Thanks,Árni
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.