Ask questions and find answers about TimeXtender Data Integration and TimeXtender Classic desktop applications
Recently active
Hi community, I am trying to work with the LinkedIn API to retrieve details about UGC posts (i.e. engagements, clicks, etc.). This information is not part of the LinkedIn Marketing Solutions CDATA connector, so I am using the CDATA provider for REST 2022. I first made a call to the posts API to ‘Find Posts by Account’: Posts API - LinkedIn | Microsoft Learn. After that I need to pass each Post ID into the Organizational Entity Share Statistics API to ‘Retrieve Statistics for Specific UGC Posts’: Organization Share Statistics - LinkedIn | Microsoft Learn. The problem I am facing is that the Posts API returns two types of posts (which cannot be filtered in the API): shares and UcgPosts. Each of those types of posts needs a different URL format in the ‘Organizational Share Statistics’ API. So, I need a way to only pass one type of post into the second API. UCG posts are posts where the ID starts with 'urn:li:ugcPost:'The file RSD 1.txt works, until the first ID from the Posts API is a Ucg
I’m testing out the new version of TimeXtender. I’ve downloaded the newest version of SQL Server that was suggested in the training material. I’ve created ODX and MDW instance, when I try to deploy a table in the MDW instance I get the following error: Not supported in current SQL version Version:Microsoft SQL Server 2022 (RTM) - 16.0.1000.6 (X64) Oct 8 2022 05:58:25 Copyright (C) 2022 Microsoft Corporation Developer Edition (64-bit) on Windows 10 Enterprise 10.0 <X64> (Build 22621: ) (Hypervisor)
I’m struggling with the TimeXtender SAP Table Data Source version 18 in ODX Server v6429.1. In our current setup we use Table Name filtering like this: Please see the wildcards used. How does this translate to ODX Server v21? I have these three rules: The latter does not seem to work. I tried many variations (and did a sync data source consecutively), but when I click Select Tables under a transfer task, it only comes up with the tables matchin an equal-rule. Tables that should match a like-rule never show up: Using equal and wildcards doesn’t work either Any advice on how I should filter tables properly?
In the release notes for 6429.1 it says that conditional lookup fields are available “in preview” for deployments in Snowflake. What does this mean?
Hi community,I have a MariaDB data source which I connect to using ODX Server (v 6346) and the CData/ADO.net connector for MariaDB v 23.0.8565.0.The source database is set to collation utf8mb4_general_ci. I noticed by copying from ODX Server to a Data Area that some special characters are slightly different than the source/ODX. I can fix this by manually changing the data type to nvarchar instead of varchar, but that is a lot of field editing.The Override Data Type function can help as well, but as we have a wide range of field lengths, this also means a lot of override rules.Is there a way to tell ODX Server that all varchar fields should be unicode/nvarchar by default (eg. based on the source database collation)?Example from ODX Server. These fields should all be nvarchar(xx) instead of varchar(xx): Implementing this idea would work for me as well :) In TX v20 Business Units, we had this option:
Hi,I want to use mapping set to map several ODX tables with the same table structure to a single DW table.The problem is that I also want to create additional “custom fields” in the DW table, and since these fields do not exist in any of the ODX tables, the mapping set excludes all the ODX tables and I am left with an empty DW table. Is there a work around to this? or am I perhaps doing something wrong?This is my DW table: The bolded fields with descriptions do not have mappings to them, they instead have custom transformations.I have used “convert to mapping set” to get the mapping set, and then adjusted it so both tables match the mapping set rules.As seen below, both tables are then excluded since neither have the custom fields. Is it necessary that all fields have at least one mapping to them?
Hi,We are unable to set up Notification on Critical Errors for the ODX Server. Both service and database for the ODX is on prem. The Exchange Server is deployed as a hybrid. TimeXtender version 6221.1This is the error message: Setting up notification for the executions in the MDW’s and SSL’s is no problem. No authentication is required by the Exchange server.BRAnders
Hi all,For one of my current client's we are rectrieving a warning while syncing the odx. The task is completed and we can transfer the data. but the warning is a bit odd.We already tried to remove the folder from the data lake and try a full load. but this didn't fix the warning. Anyone any ideas?
I’ve detected an error (sended to support) with the packages that use full load and if the incremental rule it’s defined with a datatime field.The error it’s in the ODX transfer and I’m using a SQL data source.Hope this help you.
I am working on a project with 3 environments Dev, UAT, and Prod. I scheduled ODX transfer task to run every 15 minutes.But any scheduled tasks are not working, I have to run the transfer tasks manually Regards
I’ve two tables, A and B, and I want a full outter join to obtain a table C like in the image:In T-SQL it would be:SELECT COALESCE(A.Id, B.Id) AS Id ,A.ValueA AS ValueA ,B.ValueB AS ValueBFROM TableA AS A FULL OUTTER JOIN TableB AS BON A.Id=B.Id Is it the only way to use a custom view?
Hey, Usually when an execution package fails to start it is due to another already running, then in the event viewer we get a message like this: Here, we see that the issue is due to another package. Now I have noticed that we occasionally also get messages like this one: Difference being that it does not show which ‘other’ package is causing this issue. Is this a common occurrence?
Hello,We just upgraded our sandbox to release 6429.We created environments, and Copied from Dev to Test without problems in the portal. Both MDW and SSL. SSL was mapped to the correct MDW.But after we copied from Test to Prod this error came when we tried to deploye Data Area DSA in MDW Prod. Error details in attached text file.BRAnders
Hi guys, I cannot get the companies and deals table to execute in the ODX phase. The error I get: Executing table [HubSpot].[Companies]:failed with error:System.Data.SqlClient.SqlException (0x80131904): Execution Timeout Expired. The timeout period elapsed prior to completion of the operation or the server is not responding. ---> System.ComponentModel.Win32Exception (0x80004005): The wait operation timed out Has anyone else seen this before?
Hi, I believe this is a bug but perhaps intentional. When a field in the DSA is set to ‘Raw’ , you can still map it to the MDW. When you do this the field is not mapped (as it is impossible), however the table does become dirty (red). Then, when you refresh the instance, the field is actually added in the MDW, but not mapped. I attached a GIF that shows this.
I’ve a location with multple different json files. Can i use one connector to this directory and transfer each json file, or need i to make one connector for each file? For csv files i can use one connector, for json it doesn’t seem to work this way...
Hey.This is maybe obvious - but I’m struggling to find the proper documentation, hoping someone can point me. We have TimeXtender version (20.10.42.64) on a remote server at the company I’m with, and I'm new in a data analyst role. We have the need to connect a new data source, Hubspot, to TimeXtender. Is there only general documentation to connect new data sources or is there specific documentation related to Hubspot?
Hi,I have a JSON data source that looks something like this{ "company": { "companyId": 1, "name": "AdventureWorks", "description": "" }, "hierarchies": [ { "depths": [ { "depth": 0, "name": null }, { "depth": 1, "name": "Company" } ], "allKeys": "1|-1|10" } ], "slicer": null, "userToGroup": "Username,GroupId\nJohn,G1\nSarah,G1\nPeter,G1\nKate,G1", "groupToKey": "GroupId,Key\nG1,10\nG1,101\nG1,102\nG1,103\nG1,104"}And I am only really interested in the last two objects, userToGroup and groupToKey, which both are in a CSV format. Is it possible to use something like xPath to navigate to these two objects and then parse them as CSVs? I have an RSD file that gives me userToGroup:<api:script xmlns:api="http://apiscript.com/ns?v1" xmlns:xs="http://www.w3.org/2001/XMLS
I am connecting to an Openedge Progress database via ODBC drivers. After finding out the password needs to be set in the registry, I am able to connect to the source (test connection from the Data Source properties is succesful).My sync task however fails because the datasource is not querying the correct metadata tables. In Progress, metadata for tables, columns and views is stored in the tables SYSTABLES, SYSVIEWS and SYSCOLUMNS. In the advanced settings of the datasource I am able to point out the correct column names, but not the correct tables (see screenshot below).Does anyone know how to point the datasource to the correct metadata tables?
Hi all, at a client we have encountered a curious situation with execution e-mail notifications, hopefully you will be able to help us figure it out.There are 5 scheduled execution packages for BU's that run every morning. Since two days we are getting e-mail notifications saying these have failed, but when we look in in TimeXtender they in fact have executed successfully.Each BU execution throws a different connection error message:ERROR [HY000] [MySQL][ODBC 8.0(w) Driver]Can't connect to MySQL server on 'XXXXXX' (10060) Unable to connect to any of the specified MySQL hosts. The remote server returned an error: (400) Bad Request. [500] Could not execute the specified command: HTTP protocol error. 500 Internal Server Error. ERROR [08001] could not connect to server: Connection refused (0x0000274D/10061) I will take the top one as an example to show you how it looks. Attached is the full fail notification e-mail.This package includes has the following settings: This is what the executi
What does “Remove Unused Objects” do? I cannot find documentation about it. Thx!
Hello, To my understanding TimeXtender determines the data type of a column based on first x amount of rows, depending on your setup in the portal. The fields in my source come in as (dd.mm.yyy) for example: "05.03.2021”. I use a Storage Account with a CSV connection. I would expect that TimeXtender creates a "date” date type out of this. However, is seems that if a field character starts with a '0’, it skips it. In the ODX it shows an Integer value '5032023’.ODX: Depending if a character starts with a '0’ the fields (dates) show up like: It counts for all date fields and costs me a lot of time to create a work around each time. I tried to override the datatype in my data source but without succes. Help would be much appreciated.
At one of my clients we are using the ODX and they set it up that for every different type of load they added the data source multiple times. So for the normal full loads there is 1 source . For the incremental loads of the same source there is a different source.In the data source selection the include only the tables they need for the full load. and they do the same for the incremental. But from time to time task wil not execute without showing up in the execution log without an error. I have the feeling that because the includes je indirectly exclude the other tables and if they are running at the same time this cancels each other out. In the windows logs you can see that the package then is skipped but it's no where to be found in TX.Does anyone have an explenation about this and/or an idea how we can fix this?My idea was that maybe putting everything in 1 source and then create 2 different transfer task instead of 2 different sources would fix this problem. Would love to hear from
Hi, I am syncing my data between ODX (csv files) and my DSA_Clean data area (Data waehouse). No i’m constantly getting an error that 1 of my previous inserted rows doesn’t exist anymore. I’ve tried to sync all my possible steps, so ODX, Source, Data are, but I keep getting the error and I don’t know hpw to resolve this problem.I tried several steps:1 Add the table as new table in my datawarehouse area, but still same error.2 Remove and add column again
Why does the app registration for the ODX need owner permissions on the resource? I would think that read/write permissions would be sufficient. Why does TimeXtender need the “extra” rights?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.