Ask questions and find answers about TimeXtender Data Integration and TimeXtender Classic desktop applications
Recently active
Hi all,We are unable to run two execution packages concurrently on the same instance. They are scheduled using Jobs. The packages have no common tables involved. We have made sure to check the other package under “Concurrent packages” under Edit Execution Package (and deploying after).Is running packages concurrently supposed to work when scheduled using Jobs?Will it be supported with Orchestration?Thanks for any input!Version: 6766.1
Hi,we have an Afas datasource via provider cddata rest 2023. The Afas getconnector has been updated with new columns. When i run the sync task for this Afas datasource i expect timex to detect the new columns but this is not the case. What do i need to do to let timex see this new columns? thank u in advance,Bob
Hi,we have created a new datasource for Azure Active Directory(Entra ID) via “cdata ado.netprovider for azure active directory 2022”de sync task runs ok but the transfer task keeps giving a completed with error signal. I have discussed this error with a consultant and a system/ authorization specialist but we cannot get it right. The error we are getting is(first part of the error): Executing table azuread_users:failed with error:System.Data.CData.AzureAD.AzureADException (0x80004005): [500] Could not execute the specified command: [Authentication_RequestFromUnsupportedUserRole] User is not in the allowed roles. ---> cjo220x.BG: [Authentication_RequestFromUnsupportedUserRole] User is not in the allowed roles. ---> cjo220x.Qt: [Authentication_RequestFromUnsupportedUserRole] User is not in the allowed roles.please advise us how to handle this. thank you in advance,Bob van Ierssel
It seems like we have packages within a process which are stuck on “running”:Exmon DG DesktopIf I check the “Process Queue” in the webportal, like this post suggested, I can’t find anything running.Is there another way to stop these packages? Or maybe they are not running at all, the desktop application just says so.We’ve tried to restart the virtual machine where the services are running.We’re running TimeXtender Data Governance 23.3.0.40 (aka Exmon) and TimeXtender Data Integration 6814.1.
We are experiencing a small issue with one of the connectors while using managed queries. When I use the query tool, we are utilizing the SQL endpoint from a Fabric Lakehouse to retrieve the data into the ODX. When I query the DBO table, I receive 12 records. For example, when running this query:SELECT [SinkCreatedOn], [SinkModifiedOn], [omoperatingunitnumber], [modifieddatetime], [modifiedby], [createddatetime], [createdby], [dataareaid], [recid], [tableid], [createdon], [modifiedon], [IsDelete] FROM dbo.[omoperatingunit] I also get 12 records. However, when we transfer this managed query, we only receive 11 records. This issue has occurred with multiple tables. We are not applying any filters to this dataset.Do you have any idea why this might be happening? Manually excluding or including all the columns is not manageable on the scale we are working with, so we rely on writing managed queries.
I believe I followed the instructions I found here: But for some reason it wont work on my end, or maybe i’m doing something wrong? I’m using TX version 6745.1 which is one of the latest. I have set the column that gives me the error to convert to text.After that I double checked to see if TX would indeed override the datatype and turn it into text. I synchonize again and try to transfer. But for some reason it keeps throwing me the error:Message: Error obtaining value '25-mei-1991' for column 'Geboorte Datum'. Failed to convert to datatype: 'datetime'. The original datatype of the column is: 'datetime'.Am I missing how this is supposed to work, or am I doing something wrong?
Is it possible cancel a Job in some of these status?
Hi all,I'd like to start a discussion about the batch cleansing option. You can find this option in: Table Settings → Performance → Enable batch data cleansing. This option is disabled by default. I'm looking for best practices when you should use it and how to determine the best batch cleansing size.I normally enable it on big tables (5.000.000 + rows), this reduces the disk space used for logging. But in some cases it also improves performance. It can result in faster loading of a table. However, I'm always struggling determining the correct batch size. I know the answer will be ‘it depends’. But I'm trying to find some best practices for this option.For now I start at 250.000 rows for batch cleansing and increase with 250.000 rows. I write down the timings and pick the best setting. This setting depends on the number of rows and number of transformations in the table. I'm curious if there are any practices or tips and tricks for this?
During deployment of a tabular endpoint in 20.10.44.64 the error listed below occurs. The same error appears for multiple people in my organization, also in TimeXtender 6346.1The error only occurs when deploying, not when executing. In SQL Server Management Studio (Analysis Server), the executed tables do occur, but remain empty. Naturally, connecting to the endpoint in Power BI is not possible. Error:Failed to save modifications to the server. Error returned: 'The following system error occurred: A device attached to the system is not functioning. The following system error occurred: A device attached to the system is not functioning. The following system error occurred: A device attached to the system is not functioning. The following system error occurred: A device attached to the system is not functioning. The following system error occurred: A device attached to the system is not functioning. The following system error occurred: A device attached to the system is not functio
All Execution packages with a schedule do not start at the time given. It starts always seconds to minutes later than the schedule indicates. Why doesn't it start according to the schedule?It happens with almost all packages. It also varies by package. The same package can start seconds later or 2 minutes later. For example: in the screenshots you can see that the package always starts later than 05:00 as scheduled.
Hello,Sometimes a picture says is all, but to be complete:I set my incremental load rule on my datasource to mach any field containing ‘UPMJ’ (INT) with updates and deletes and most importantly: set the “substract from value”-value to 2. Looking at the picture above this is either not set correctly or not displayed correctly.
Dear Sir,We connect to our Excel files through a Sharepoint site with some Document Libraries. Works fine, but the performance is bad 😑 -5 minutes wait to Select Tables -5 minutes wait to execute Synchronize 5 minutes wait for execute Full Load Is there a way to squeeze some performance out of this ? Thanks in advance for looking into this performance issue. Regards,Arthur
Hi,I updated our TX version to the newest 6814.1 I have added many tables in TimeXtender Ingest Server with incremental load. Why do I have to change all incr. tables in "desktop app" to explicit incremental load, can't you use “Automatic” anymore? Error msg: when executing with automatic on a table with incr setup from the datasource I get this type of error “Invalid object name 'shema.table_I'.” Something I haven't done right... regards,Bjørn A.
Dear Sir,I want to connect to a PostgreSQL database via ODBC.So I found these posts how to fix this. But I am using TX version 6766.1.Can someone please point me the way how to fix this with the latest and the greatest version of TimeXtender.See Word document in the attachment with my setup.https://legacysupport.timextender.com/hc/en-us/articles/4410466782621-Create-a-ODBC-data-source-in-a-ODX-or-with-a-Any-Source-ADO-Net-provider-in-a-Business-UnitThanxs in advance.Regards,Arthur
I am deploying a project to Snowflake.On a table I get the following error:Object reference not set to an instance of an object.As read in another ticket I did a ‘Save and reload' but unfortunately that did not solve the issue.It;s on deploying the data cleansing script however it does not show me the script in the deployment log, I only see the error message. Is there an easy way i can see what lookup column is causing the issue ?
I am trying to load a semicolon csv file with ODX (version 6766.1)The output is just 1 column.What box do I have to tick in the app portal to seperate the collumns on ; (semicolon) ?Regards,Arthur
Hi all,I am currently working with a client who is using TimeXtender version 6766.1 in an Azure environment. We are trying to ingest data from a source that generates JSON files stored in a hierarchical folder structure organized by date and hour. The folder structure is as follows:subject/version/date=YYYY-MM-DD/hr=HH/*.jsonExample Path: dev/Call/1.2/date=2024-10-30/hr=14/*.jsonWithin each hr=HH (hour) folder, there may be one or more JSON files. Similarly, each date=YYYY-MM-DD (date) folder may contain multiple hour subfolders, though it's rare for all 24 hour subfolders to be present.I have successfully configured the data source connector in TimeXtender to read all JSON files from a specific hour folder, as shown in the example above. However, our goal is to configure TimeXtender to ingest all JSON files across all date and hour subfolders under the main path:dev/Call/1.2/ When I attempt to use wildcards to achieve this—such as:dev/Call/1.2/*/*/*.json I encounter an error stating:E
Hello,I am encountering a challenge with the REST connector when it deals with JSON data that includes empty property names. This issue arises specifically during the conversion of JSON to XML.The REST connector fails when trying to convert JSON data that contains properties with empty names. Here is the error message I receive:Failed to execute endpoint 'authenticate':XmlNodeConverter cannot convert JSON with an empty property name to XML. Path 'TX_Autogenerated_Element.menu.categories.', line 1, position 94530. This error stops the ingestion process because XML does not support tags with empty names, which are present in the JSON structure. This is the problematic part of the JSON structure:{ "categories": { "": { "collapsed": false, "description": "<No Category>", "id": "" }, "BUD": { "collapsed": false, "description": "Budget", "id": "BUD" } // Additional categories }} I
HiWe experienced for the second time a failure with our overnight TX jobs not running (first time was on 16 Sep) and on investigation we were not able to open up the ODX in TimeXtender (same issue as already logged here https://support.timextender.com/ingest-89/tx-freezes-when-opening-the-odx-2248)Could not manually stop and restart the [TimeXtender_Ingest_Service_6744.1] service, so had to manually kill the task from the CMD and rerun the [TimeXtender Ingest Service Configuration 6744.1] tool.In the other post the conclusion seemed to be that this issue had now been resolved, but for us the issue has now occurred twice in the last 6 or so weeks.Is this still a known issue?TimeXtender Ingest 6744.1TimeXtender Data Integration 6745.1
I would like to test this new functionality.I’ve read: https://support.timextender.com/deliver-109/rest-api-endpoint-1808?tid=1808&fid=109But I can't understand how to send the tables from the SSL instance to the target DB using this technique. Can you explain me with a clearer example?
Hi, I'm currenty developing the GA4 connector in TimeXtender. With some other tips and tricks of other posts it was quite simple to create the connection. At this moment I have 7 different properties from where all data should be loaded. I've read multiple posts but haven't found a solution to extract data dynamically over a list of properties. Current setup:CData Connector -- Google Analytics In this connector I can filter on property ID. TimeXtender -- v6xxxx + ODX Creating managed Queries to filter the relevant data from [GlobalAccessObject]. But haven't found a property id in this list. I think that currently the only option is to create for each property one connection. Or has someone found another solution?
Hi, we are in a project to update our on premise ERP system Infor to the current version Infor LN CE which is running on the cloud. Since we cannot access the database then directly we are currently checking how to ingest the data to TimeXtender in future. There is a tool within the ERP suite to provide the data to "Infor Data Fabric" which is an Amazon S3 data lake where the ERP data is stored in JSON files. This data fabric provides a SQL Endpoint to query the data. So similar architecture as in MS fabric with lakehouses. The data can be queried in two ways:- JDBC: using a JDBC driver with API Gateway authentification, see Link- API: handle API request in a certain order to start a query job, aks its status and get the results, see link: https://www.youtube.com/watch?v=m4d0awIQ6AgFor TimeXtender, which would be the way to prefer? I could not find the possibility to add a JDBC datasource with API authentification and I am wondering if TimeXtender can handle the process order
Hello everyone,I'm facing an issue with TimeXtender when trying to retrieve tables containing datetimeoffset columns through the Generic ODBC Data Source connector. The datetimeoffset columns aren’t coming through, and in the ODBC settings, the option to override datetime types is greyed out, which I thought might solve the issue.Has anyone encountered this or found a workaround to retrieve datetimeoffset data through ODBC in TimeXtender?Thanks in advance!
Hi!Getting this error when I try to open the Dev instance. Test and Prod is OK.I could open an earlier version of the project but after I made some changes and tried to save and deploy, I first got a warning that said that this was not the latest version. When I chose to save anyway, I got the same error. Is there some way to “force save” to make this earlier version the latest one and get rid of the error?
Hi,I was wondering if it's possible to use multiple ODX instances for different enviroments (DEV/ACC/PRD).I know that at 20.10 you could only use a single ODX as after multiple enviroment transfer all mapping to ODX would be lost when using multiple ODX instances Is this still the case? Is this issue solved in next-gen?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.